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LapLink USB Network Cable (TCP/IP) Troubleshooting in Windows 98 and Windows Millennium

Document relates to:   LapLink Classic, LapLink Gold 11.x, LapLink Gold, LapLink 2000

 

SUMMARY

I installed the USB Network cable, but I do not see a connection in LapLink. What can I do?

 

CAUSE

Many things can prevent LapLink from connecting with the USB Network cable. In some cases finding the problem is easy, while in others, more advanced steps are necessary.

Attention! The LapLink USB Drivers described in this document support USB 1.1 only. Please check with your computer manufacturer to see if you have USB 2.0 ports.

For USB 2.0 compatibility, you must use Laplink Gold 11.5 (or higher) and the Gold USB cable, or the optional IOGear High speed cable. For assistance, see Technical Document 1036: LapLink USB Connection Troubleshooting in Laplink Gold 11.5

Laplink Gold 11.5 is a free point-release to registered Laplink Gold 11 users.

 

SOLUTION

Basic Troubleshooting


Easy-to-resolve Problems
See Technical Document 630: Quick Tips for Using the USB Network Cables with LapLink Gold for information on easy-to-resolve problems, Installation Requirements, LapLink Security and Port settings, and other hardware considerations.

Knowing your Cable
Check the Help, About LapLink box to determine the exact update of LapLink Gold that is on the computer. Use the information below as you are checking the installation.

If you find that the wrong drivers are installed for your cable, go to the Cable Drivers page to download the correct drivers.

Note: All versions of LapLink Gold will work with either the gold or translucent purple cable. The information listed here are the defaults for each version.

Cable color: Translucent Purple
Driver as listed in Add/Remove Programs: LapLink USB Network Cable
Network Adapter name: LapLink USB Network Cable
Universal Serial Bus Controller: USB-USB Network Bridge Driver

Cable color: Gold
Driver as listed in Add/Remove Programs : LapLink, Inc. USB Cable Network
Network Adapter name: LapLink, Inc. USB Cable Network Adapter
Universal Serial Bus Controller: LapLink, Inc. USB Network Cable

Checking for Other Devices
When Windows is not able to install a new hardware device, it adds the device to the Other Device category. If LapLink's USB Network cable is in this category, LapLink will not connect.
  1. Open Device Manager. See Technical Document 359: How to Open Window Device Manager for more information.

  2. Look for the Other Devices category.

  3. If present, look for a USB Cable or LapLink Cable device.

  4. If present, highlight the device and click Remove.

  5. Take the USB Network cable off the computer. Wait 10 seconds and reattach the cable to the USB port.

  6. Look for the USB Network cable in the Universal Serial Bus Controllers category.

  7. Confirm that the Other Devices group has been removed.

  8. Try a LapLink connection.

Checking for a Correct Installation
A correct installation has two parts:
  • Network Neighborhood or My Network Places lists the LapLink USB Cable Network Adapter. Alternatively, Device Manager lists the LapLink USB Cable in the Network Adapters category.
  • Device Manager lists the LapLink USB Network Cable or the USB-USB Network Bridge as a device in the Universal Serial Bus Controller category when the cable is plugged into the computer.


To check the installation:
  1. Open Device Manager. See Technical Document 359: How to Open Windows Device Manager for more information.

  2. Click View Devices by Type.

  3. Click the plus next to Network Adapters. Look for the name of the network adapter used by your version of LapLink to be listed among the adapters.

  4. Click the plus next to Universal Serial Bus Controllers. Look for the name of the Universal Serial Bus controller driver used by your version of LapLink to be listed among the devices.

If Windows reports a conflict (a yellow exclamation mark) or does not list the adapter or the cable, continue with Correcting the Installation.

Advanced Troubleshooting
Checking the installation and configuration of the LapLink USB Cable Network adapter and Universal Serial Bus controller driver installation (collectively known as the USB Network cable driver) includes these steps:
  • Correcting the Installation

  • Checking the TCP/IP Bindings

  • Adding an IP address to the network adapter

  • Testing the USB Network Connection

  • Connecting LapLink

  • Correcting the Installation:

    Remove the current installation while the computer runs in Safe Mode. Make sure that the cable is not attached to the computer when you reinstall the network adapter and cable drivers in Windows Normal Mode.
    1. Reboot your computer to Safe Mode. See Technical Document 102: How do I Boot to Safe Mode for more information.

      When Windows runs in Safe Mode, follow these steps:
      1. From the Windows Start menu, point to Settings and click Control Panel .

      2. Double-click Add/Remove Programs.

      3. Double-click LapLink USB Cable Driver.

      4. Click OK when prompted to confirm the removal.

      5. Click No when prompted to reboot the computer.

      From Control Panel, double-click System.
      1. Click the Device Manager tab.

      2. Click the plus next to Network Adapter.

      3. If any LapLink USB network adapters are listed, highlight it and click Remove.

      4. Click Yes to confirm the removal.

      5. Click the plus next to Universal Serial Bus Controllers.

      6. If any LapLink USB controllers are listed, highlightit and click Remove .

      7. Click Yes to confirm all removals.

      8. Click Close

      9. Confirm that the cable is not connected to the computer and reboot the computer.

      10. Return to Device Manager and confirm that the LapLink USB network adapter has been removed. If it is still listed, see Technical Document 657: Windows Device Manager Reports that the USB Network Cable Network Adapter is not Working Correctly for more information.

    2. Re-install the USB cable drivers from your LapLink CD-ROM or by downloading them from the Cable Drivers page.
      Note: You may see a Computer Name and Workgroup field when installing the drivers. Confirm that these fields have no spaces or punctuation. Correct if necessary. Some versions of the drivers do not display these fields.
    3. Retry the LapLink connection. If it continues failing to connect, follow the steps in the next topic to check the TCP/IP bindings.


    Checking TCP/IP bindings
    TCP/IP is the network language used to create the USB Network connection. Some versions of Windows limit the number of network adapters that can use TCP/IP. If your computer has too many bindings (the connection of the network adapter to the TCP/IP protocol), then Windows does not recognize the USB Network cable.
    1. Open Network Neighborhood or My Network Places Properties. See Technical Document 684: How to Open Network Neighborhood Properties or My Network Places Properties for more information.

    2. On the General tab, count the number of TCP/IP bindings in the list of installed components. They look like this:

    3. TCP/IP --> The name of a network adapter
    4. If there are more than five bindings INCLUDING the LapLink USB Network binding , you must remove unused bindings.

      1. To remove a binding, highlight it and then click Remove.

      2. Note: Please contact LapLink, Inc. Technical Support if you need assistance in determining which bindings can be removed.
      3. Click Apply, then OK and reboot the computer when prompted.

    5. After removing unused bindings or if the number of TCP/IP bindings meets the requirements, try the LapLink connection again. If the connection fails, continue to the topic Adding an IP address to the network adapter.


    Adding an IP Address to the network adapter:

    A word about IP addresses. IP addresses and Subnet Masks are like a person's name. The first name is always unique to the person, while the last name is common to the family. In a similar way, an IP address is always unique to the network adapter, and the Subnet Mask is the same for all related adapters on the network.

    We suggest using one of these two address ranges. Use the same range on all of your computers. Check the TCP/IP bindings of other network adapters so that you select a unique range for the LapLink USB Network adapter. The first computer will use 10.0.0.1; the second computer will use 10.0.0.2, etc. X is a variable that changes for each computer.

    Range 1: IP Address 10.0.0.x Subnet Mask 255.0.0.0
    Range 2: IP Address 172.29.61.x Subnet Mask 255.255.0.0

    1. Close all open programs.

    2. Open Network Neighborhood or My Network Places Properties. See Technical Document 684: How to Open Network Neighborhood Properties or My Network Places Properties for more information.

    3. Double-click the TCP/IP binding for the LapLink USB Network adapter. The binding looks like this:
      TCP/IP --> The name of your LapLink USB Network adapter
    4. On the IP Address tab type:


    5. For the first computer, type

      10.0.0.1 for the IP Address
      255.0.0.0 for the Subnet Mask

      For the second computer, type:

      10.0.0.2for the IP Address
      255.0.0.0 for the Subnet Mask

    6. Click OK .

    7. Click Yes to restart your computer. The Universal Serial Bus controller driver is now configured to use a static IP address.

    8. Reboot the computer if prompted, and then go to the next topic to test the connection.

    Testing the USB Network connection:

    See Technical Document 171, Using the PING Command to Test Network-Type Connections for complete instructions.

    If the Ping test is successful, then go to the Connecting LapLink.

    If PING fails,
    1. Review suggestions listed in Technical Document 171.
    2. Review all of the steps outlined here again.

    3. Uninstall the Universal Serial Bus controller driver only. For steps to do this, click Correcting the Installation. Reboot the computer with the USB Network cable still attached to the computer. Windows will reinstall the cable.

    Note: LapLink support technicians are not trained to resolve problems where PING fails. The list of suggestions given here is as a service to our users. For detailed troubleshooting, please contact your network administrator, or other Windows technician.

    When PING is successful, then go to the Connecting LapLink.

    Connecting LapLink:
    1. Launch LapLink on both computers.

    2. Attached the USB Network cable to both systems.

    3. In LapLink, click Connect Over... USB Network .

    4. Click on the TCP/IP Addresses tab.

    5. In the TCP/IP name or address box, type the IP address of the computer you wish to connect.

    6. In the Services area, select the LapLink service you wish to use once connected.

    7. Click OK.


    Note: If the connection fails, recheck the LapLink Port and Security settings. See Technical Document 630: Quick Tips for using the USB Network Cable with LapLink Goldfor more information.

    You can automate this connection by creating an Address Book entry. To do this, follow these steps:
    1. From the LapLink Link bar, click the Address book icon.

    2. Click Add.

    3. Type in a descriptive name in the Description field.

    4. Type in the LapLink computer name of the computer you are connecting to in the Computer Name field.

    5. From the Connection Type drop down list, click Network: TCP/IP Address.

    6. Type in the IP address of the computer you are connecting to.

    7. Click OK and Close.



     

    This Article can be found by searching for:

    Keywords:   Cable: USB Network (gold)Configuration: Cable driversCable: USB Network

    Platforms:   WinMe, Win98/SE

     

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    Last updated: Thursday, February 26, 2004

    Article #683

    Legacy Article #